Neuer Bereich: Plugins made by Boxpirates - Plugins die direkt hier aus unserem Board kommen



Einstellungen Enigmalight mit ESP8266 (WLED) an USB

    #WirBleibenZuhause
    Hilf mit, das Coronavirus zu stoppen
    1. Achte auf Deine Mitmenschen
    2. Halte Abstand zu anderen
    3. Wasche Deine Hände häufig
    4. Huste und Niese in Deine Armbeuge
    5. Berühre Dein Gesicht nicht
    6. Halte Dich an die gültige Allgemeinverfügung

    Mehr Infos vom Bundesministerium für Gesundheit hier!
    Wir danken allen, die in dieser Krise Unglaubliches leisten.

    • Einstellungen Enigmalight mit ESP8266 (WLED) an USB

      Einstellungen für Enigmalight und ESP8266 an USB.

      Source Code

      1. - Gerätetyp: Adalight/Momo
      2. - Geräteausgabe: /dev/ttyUSB0
      3. - Geräterate: 115200
      Installierte zusätzliche Pakete:
      kernel-module-ch341, python-cheetah, curl, kernel-module-usbserial

      Source Code

      1. apt-get install kernel-module-ch341 python-cheetah curl kernel-module-usbserial
      gruß pclin
      Files
      Dreambox ONE, DM920UHD, DM900UHD, DM820HD HDD + USB-HUB, Stick 64GB, USB-HDD, Wireless Touch Keyboard K400r, Wlan-Stick 11n
      (Flash) DP-OE2.6 (BAXII) eigenes OE2.6, Debian-Buster, Diverse
      (Flash) DP-OE2.5 (BAXII) eigenes OE2.5-e2+kodi+X, debian-stretch, Diverse
      AudioDSP: miniDSP 2x4HD
      TV: LG 65" SUHD
      Hyperion und Plugin HyperionControl auf der Dreambox One
      nodeMCU ESP8266 mit WLED Wlan 268 LED's SK6812-NW 60 LED/m



      Ambilight for ever

    • nabend ich hab eine uno 4kse mit vti hab sonst per WLAN betrieben auf dem node ist wled installiert per WLAN geht alles ..

      Versuche grad per usb es zum laufen zu bringen..

      root@vuuno4kse:~# enigmalight -m 2
      [InitLog] start of log /home/elight-addons/.e
      nigmalight/enigmalight.log
      [CConfig::LoadConfigFromFile] Opening /etc/enigmalight.conf
      [CConfig::CheckConfig] checking config lines
      [CConfig::CheckConfig] config lines valid
      [CConfig::LoadConfigFromFile] Opening /etc/enigmalight.conf
      [CConfig::BuildConfig] building config
      [CConfig::BuildConfig] built config successfully
      [main] Start device 1 from 1
      [CDevice::Process] ambilight: starting with output "/d
      ev/ttyUSB0"
      [CDevice::Process] ambilight: setting up
      [CDeviceRS232::OpenSerialPort] ERROR: ambilight: /dev/ttyUSB0: ope
      n() No such file or directory
      [CDevice::Process] ERROR: ambilight: setting up failed
      ...
      [CDevice::Process] Exiting EnigmaLight...
      root@vuuno4kse:~#

    • Es sind alle Pakete installiert...

      Wenn ich das eingebe

      dmesg | grep tty

      Bekomme ich diese Meldung


      oot@vuuno4kse:~# dmesg | grep tty
      0.262708] console [ttyS0] disabled
      0.262735] f040a900.serial: ttyS0 at MMIO 0xf040a900 (irq = 107
      base_baud = 5062500) is a 16550A
      0.993384] console [ttyS0] enabled
      0.997192] f040a940.serial: ttyS1 at MMIO 0xf040a940 (irq = 108
      base_baud = 5062500) is a 16550A
      1.006424] f040a980.serial: ttyS2 at MMIO 0xf040a980 (irq = 109
      base_baud = 5062500) is a 16550A

    • @dack23
      Hast du auch schon unser WLED-Flash-Tool installiert plugin-wled-flash-tool?
      Hier sind dann alle Abhängigkeiten mit dabei, dann sollte dein Modul auch erkannt werden.
      Wenn du dein Modul damit Updaten flashen kannst, sollte es auch mit Enigmalight funktionieren.

      Vielleicht hilft dir das erst mal weiter.

    • Ein Auszug aus der conf alle benötigten kernel module wie am Anfang beschrieben sind installiert

      [global]
      interface 127.0.0.1
      port 19333
      [device]
      name ambilight
      output /dev/ttyUSB0
      type momo
      interval 20000
      prefix 41 64 61 01 03 57
      channels 780
      rate 115200
      debug off

    • Der ESP wird nicht erkannt.
      Mit Netzteil mit Strom versorgen.
      Und anders USB Kabel versuchen.

      Gruß pclin
      Dreambox ONE, DM920UHD, DM900UHD, DM820HD HDD + USB-HUB, Stick 64GB, USB-HDD, Wireless Touch Keyboard K400r, Wlan-Stick 11n
      (Flash) DP-OE2.6 (BAXII) eigenes OE2.6, Debian-Buster, Diverse
      (Flash) DP-OE2.5 (BAXII) eigenes OE2.5-e2+kodi+X, debian-stretch, Diverse
      AudioDSP: miniDSP 2x4HD
      TV: LG 65" SUHD
      Hyperion und Plugin HyperionControl auf der Dreambox One
      nodeMCU ESP8266 mit WLED Wlan 268 LED's SK6812-NW 60 LED/m



      Ambilight for ever

    • Wenn kein /dev/ttyUSB0 vorhanden ist wird auch das WLED Flash Tool nicht funktionieren.

      Normalerweise wird per Hotplug das Device erkennt und die kernel-module (Treiber) geladen.
      Danach ist dann /dev/ttyUSB0 sofort verfügbar.

      Mit lsmod kann man sich die geladenen module ansehen.

      Source Code

      1. [18:29 root@dreamone ~] > lsmod
      2. Module Size Used by
      3. ch341 16384 0
      4. usbserial 45056 1 ch341
      5. ...
      6. ...


      Die beiden module müssen dann in der Auflistung vorhanden sein, wenn das nicht der Fall ist, kann das in seltenen Fällen daran liegen das kein Netzteil am ESP ist.
      Das USB Kabel, USB Buchse oder der Hotplug nicht funktioniert.

      Den ESP an einen PC anschließen und schauen ob er dort erkannt wird.
      An der Box kernel-module von Hand laden.

      Source Code

      1. modprobe ch341
      2. modprobe usbserial
      Mit lsmod schauen ob die module geladen wurden, dann ESP anstecken.
      Dann checken ob ttyUSB0 vorhanden ist.

      Source Code

      1. [18:37 root@dreamone ~] > ls /dev |grep USB
      2. ttyUSB0
      Wenn das alles nichts bringt habe ich leider auch keine Idee mehr.

      gruß pclin
      Dreambox ONE, DM920UHD, DM900UHD, DM820HD HDD + USB-HUB, Stick 64GB, USB-HDD, Wireless Touch Keyboard K400r, Wlan-Stick 11n
      (Flash) DP-OE2.6 (BAXII) eigenes OE2.6, Debian-Buster, Diverse
      (Flash) DP-OE2.5 (BAXII) eigenes OE2.5-e2+kodi+X, debian-stretch, Diverse
      AudioDSP: miniDSP 2x4HD
      TV: LG 65" SUHD
      Hyperion und Plugin HyperionControl auf der Dreambox One
      nodeMCU ESP8266 mit WLED Wlan 268 LED's SK6812-NW 60 LED/m



      Ambilight for ever

    • ok Kabel ausgetauscht und kein Erfolg deine Sachen kontrolliert...

      Usb serial lässt sich nicht deinstallieren sagt 0 von 0 entfernt also scheinbar liegt da der Hund begraben.


      ckage kernel-module-usbserial (1:4.1.20-r1.8-vti06) installed in
      ot is up to date.
      llected errors:
      parse_from_stream_nomalloc: Missing new line character at end of
      ile!

    • so hab per console deinstalliert und installiert jetz zeigt er usb an ..

      Ambilight geht nicht



      EDIT:

      glaube muss neu flashen..
      Nach reboot zeigt er bei lsmod wieder nicht an das usb serial installiert ist ....

      Lässt sich auch wieder per plugin manager nicht deinstallieren also denke da ist was faul. Ich werde mal alles neu machen

      Vielen Dank für die Hilfe denke wir kommen näher
      Files

      Post was edited 1 time, last by dack23 ().


    • New

      Hallo,
      ich habe exakt das gleiche Problem. WLED mit NodeMCU und WLAN funktioniert, am USB Anschluss wird der NodeMCU nicht erkannt. Die angeführten Kernel Module sind installiert. Ich habe verschiedene Kabel probiert, kein Erfolg.
      @dack23: Hast Du eine Lösung gefunden?