Neu: Ab sofort ist Boxpirates werbefrei!!!
... neuer Forenbereich - Smart Home - Interessant? - ... dann schaut mal rein. -> Klick


Angepinnt [Support Thread] NordVPN-Connector

    • I used an older backup image of PurE2 v.6.2 I had made and made a new install for the plugin.
      Worked without problems for the installation and actual use. I can login and access the VPN.
      Need to cleanup a bit the very large server list.
      So probably I had messed up something in the box with some trial and error installations of OpenVPN etc.

      Many thanks for the help and advice....

    • Hallo zusammen,
      plane ebenfalls das NordVPN-Connector Plugin einzubinden - habe eine DM920 mit dem aktuellsten nn2 Image im Einsatz.
      Bin aktuell noch am "Einlesen" in die Materie, man möge mir meine Unwissenheit auf dem Gebiet der Linux Boxen verzeihen.

      Um möglichst keine Fehler bei der eigentlichen Installation zu machen, habe ich mir mal den Ablauf wie folgt notiert:

      1. nn2 nochmals "clean" flashen
      2. openvpn Plugin deinstallieren falls vorhanden via "apt-get remove openvpn"
      3. Reboot
      4. Abhängigkeiten über Paketverwaltung nachinstallieren (Filter setzen); Schadet dieser Schritt, falls Abhängigkeiten über das Plugin gezogen werden?
      - "python-requests"
      - "curl"
      5. OpenVPN-Paket von Merlin in /temp schieben und installieren via "dpkg -i /tmp/openvpn_2.3.8-r0.2_armhf.deb"
      6. Reboot
      7. Plugin NordVPN-Connector in /temp schieben und installieren via
      - "dpkg -i /tmp/*.deb"
      - "apt-get update"
      - "apt-get -y -f install" im Fehlerfall "apt-get -y -f install --force-yes"
      8. Reboot

      Wäre der Ablauf aus eurer Sicht so i.O.?
      Könnte das originale openvpn Plugin bei der nächsten nn2 Aktualisierung wieder Probleme verursachen?

      Danke und Gruß,
      MAC1972

    • Hallo,
      auf einem frisch aufgesetzten nn2 Image erhalte ich beim Versuch über Telnet folgende Meldungen:

      root@dm920:~$ dpkg -i /tmp/*.deb
      Selecting previously unselected package enigma2-plugin-extensions-nordvpnconnector-oe25.
      (Reading database ... 14783 files and directories currently installed.)
      Preparing to unpack .../enigma2-plugin-extensions-nordvpnconnector-OE25_0.3-r3_all.deb ...
      Unpacking enigma2-plugin-extensions-nordvpnconnector-oe25 (0.3-r3) ...
      dpkg: dependency problems prevent configuration of enigma2-plugin-extensions-nordvpnconnector-oe25:
      enigma2-plugin-extensions-nordvpnconnector-oe25 depends on python-requests; however:
      Package python-requests is not installed.
      enigma2-plugin-extensions-nordvpnconnector-oe25 depends on curl; however:
      Package curl is not installed.
      enigma2-plugin-extensions-nordvpnconnector-oe25 depends on openvpn; however:
      Package openvpn is not installed.

      dpkg: error processing package enigma2-plugin-extensions-nordvpnconnector-oe25 (--install):
      dependency problems - leaving unconfigured
      Errors were encountered while processing:
      enigma2-plugin-extensions-nordvpnconnector-oe25
      root@dm920:~$

      Muss ich nun doch vorab die Abhängigkeiten manuell installieren?
      Falls ja, sollte dann gleich das OpenVPN-Paket von Merlin installiert werden?

      Danke und Gruß,
      MAC1972

    • Ich hatte den Nord-VPN Connector bei mir schon unter NN² auf meiner DM920 am laufen, bin jetzt aber wieder auf GP4 umgestiegen.

      NN² clean flashen, mit der aktuellen Version brauchst nur openvpn vom NN-Feed laden. Dann installierst du dir noch python-requests und curl. Danach schiebst du den Nord-VPN Connecetor in den /tmp folder und installierst du ihn offline über die Softwareverwaltung. Danach würde ich sicherheitshalber die Box rebooten. Danach gibtst du deine NordVPN-Daten ein.

    • OK - habe nun exakt folgendes ausgeführt:

      1. NN2 clean geflasht
      2. Reboot
      3. Systemaktualisierung
      4. Reboot
      5. Abhängigkeiten vom NN-Feed installiert: curl, python-requests und openvp
      6. Reboot
      7. NordVPN-Connector in /tmp geschoben und offline über die Paketverwaltung installiert (ohne Fehlermeldung)
      8. Reboot

      Das NordVPN-Connector Plugin ist jetzt unter Erweiterungen zu sehen, jedoch wird ein green screen generiert sobald das Plugin ausgewählt wird.
      Anbei der Crashlog.
      Nur zur Info: ich bin aktuell noch am Testen und habe kein Tunersignal an der Box anliegen, daher auch die Tuning-Fehler im Crashlog.

      Danke und Gruß,
      MAC1972
      Dateien

    • @MAC1972
      Deaktiviere mal IPv6 in deinen Netzwerkeinstellungen und probiere es nochmals.

      pic1.png <> Gelbe Taste (IP) <> pic_2.png


      Fragen gehören ins Forum und nicht in mein Postfach
      Kein privater Support
      No private support
      Themen zu Internet-Sharing sind hier nicht erwünscht

      NordVPN-Connector v0.3-r3 ------ Support Thread


      ... falls du das Zeug dazu hast und einen Bereich betreuen möchtest
      Werde Teil des Teams! ... und Bewirb dich als Moderator


      'boxpirates-2'

    • Hey ho,

      Habe das plugin auf meiner gigablue hd quad plus und dem letzten open atv image installiert. Nach der installation habe ich alle einstellungen durchgeführt und unter standard dns meine rojter ip hinterlegt.

      Dann abgespeichert aber danach verliesen sie ihn.

      Leider weiß ich nicht so recht in welchem log ich nachschauen kann woran es liegen könnte.

      Bitte gebt mir kurz bescheid in welchen logs ich infos finden könnte.

      Danke
      Dateien

    • Unter Einstellungen (Grün) musst du mit Lade neue Konfigdateien (Gelb), die VPN-Serverlisten runterladen, erst dann geht's weiter.


      Fragen gehören ins Forum und nicht in mein Postfach
      Kein privater Support
      No private support
      Themen zu Internet-Sharing sind hier nicht erwünscht

      NordVPN-Connector v0.3-r3 ------ Support Thread


      ... falls du das Zeug dazu hast und einen Bereich betreuen möchtest
      Werde Teil des Teams! ... und Bewirb dich als Moderator


      'boxpirates-2'

    • Hi,

      Zonk wasn deppen fehler...

      Aber leider klappt es noch nicht zu 100%

      Wenn ich nen ip tv sender oder radio an mache gehe dann in die app und will mich verbinden in dem ich einen server aussuche und ok sagen dreht sich das wartezeichen ich sehe bild im hintehrund bzw höre ton sprich die vpn muss aktive sein und dann nach kurzer zeit kommt nen fehler und auch bild / ton ist weg. Sieht so aus als würde er die verbindung aufbauen sie dann aber wieder trennen.

      Jemand ne idee leider bei allen servern so die ich getestet habe.

      Gruß

      Ah mir fällt ein, dass ich ja noch an meiner firewall vorbei muss .. :( ausgehend habe ich alles erlaubt aber eingehend nicht. Ich denke muss da morgen mal ins livelog schauen und dann melde ich mich noch mal.
      Dateien

    • Guten Morgen,

      Also an der firewall liegt es nicht egal ob any any allow oder mit amtiven regelset macht es keinen unterschied. Ich sehe keinerlei drops auf der firewall im livelog.

      Tja human error found :) habe mich beim pw vertippt und I / l sah so gleich aus... Blubb

      Sodele nun werden ich mal testen

      Gruß

      Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von justanick ()


    • Hey,I am using VU + uno 4k se, OpenAtv 6.2, v0.3-r3 installed and problems will appear here.Internet in kodi plugins stops working after 20 minutes.The NordConnector plugin is very slow (reset vu + helps).Internet at Oscam works.What can be a problem?

    • Neu

      Hallo, ich habe versucht das Plug auf meine VU UNO SE zu bringen ,klappt auch bis zur Installation nur dann sagt die Box 0 Pakete installiert !
      Habt ihr ne IDEE? Auch nach Neustart ist nix in den Erweiterungen zu finden ...

    • Neu

      Du musst das Paket zum installieren in den tmp Ordner schieben. Bei VTI funktioniert meistens das Installieren von z. B. der Festplatte nicht zuverlässig.

    • Neu

      also, ich habe selbst eine vu-... ladet euch das plugin aus dem ersten post (ipk) auspacken und mit ftp nach /tmp schieben
      dann einfach im telnet installieren mit

      Quellcode

      1. opkg install /tmp/*.ipk
      die abhängigkeiten werden mit installiert
      Gruß Reiter

      Fragen gehören ins Forum und nicht in mein Postfach




      VU+ Forum -- Box - Pirates
      EMM von Hand schreiben
      V14 + HD02 mit Easymouse am RaspiServer